Mac OS使用turtle库报No module named ‘_tkinter’

直接下载python最新版本即可,下文来自python官网

如果您正在使用适用于macOS的当前任何python.org Python安装程序(3.8.0 +,3.7.2 +,3.6.8或2.7.16+)中的Python,则无需采取进一步措施即可使用IDLE或tkinter。将使用Tcl / Tk 8.6的内置版本。

如果您使用的是macOS 10.6或更高版本,则Apple提供的Tcl / Tk 8.5有严重的错误,可能会导致应用程序崩溃。如果您希望使用IDLE或Tkinter,请不要使用Apple提供的Python。相反,请从python.org或第三方发行商那里安装并使用更高版本的Python,后者会提供或链接到较新版本的Tcl / Tk。

Python的集成开发环境 IDLE和 它使用的 tkinter GUI工具箱依赖于Tk GUI工具箱,而Tk GUI工具箱不是Python本身的一部分。为了获得最佳结果,在计算机上安装正确的Tcl / Tk版本很重要。对于可从该网站下载的用于macOS的最新Python安装程序,这里是当前建议的摘要以及更多详细信息。

发表评论